Probleme beim Erstellen von Beiträgen mit Tabellen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Probleme beim Erstellen von Beiträgen mit Tabellen

    In Mogyus Basteltagebuch ist zu sehen, dass das Forum durchaus wunderschöne Tabellen darstellen kann. Funktioniert bei mir aber leider nicht, wenn ich eine in einen Beitrag einfügen möchte. Ich habe Chrome und die üblichen "Tabelle einfügen"-Werkzeuge genutzt.

    Da beim ersten Versuch die Tabelle direkt im Forum zu befüllen, der halbe Content direkt wieder kommentarlos verschwunden ist, habe ich diese dann im Texteditor vorausgefüllt.

    Wenn ich die nun vorbereitete Tabelle im BBCode Modus in den Beitrag einfüge, wird alles korrekt angezeigt (wenn auch nicht mit so schönen Farbwechsel-Unterlegungen wie bei Mogyu). Aber schon in der Beitragsvorschau ist die Tabelle einfach weg. Bearbeite ich den Beitrag wieder, ist der zugehörige Code wieder sichtbar. Auch in der WYSIWYG-Ansicht in "lesbarer" Tabellenform.

    Was ist da los? Gibt es einen Trick, wie man die Tabelle im Forum sichtbar macht?
  • So, ich hab dann mal Chromium angeworfen, Chrome selber habe ich hier nicht.


    123
    456

    Diese Testtabelle hat ausgezeichnet funktioniert bisher, nur gepostet habe ich sie jetzt, wo ich hier schreibe, gerade noch nicht. Wenn da leer ist, haben wir ein Problem ;) .
    Die Vorschaufunktion nutzt meines Wissens nicht die PHP-Rendering-Funktionen, sondern emuliert die via JS, oder wenn doch, dann muss das auf jeden Fall noch durch Ajax. Das ist eine mögliche Fehlerquelle, die nichts mit dem Posten an sich zu tun hat. Kannst du die Tabelle mal posten? Der Farbwechsel sollte im fertigen Post dann auch auftauchen (ich hab früher schon Tabellen gepostet, halt im Firefox).
    Man kann gar nicht so rundum stromlinienförmig sein, dass es nicht irgendeine Pappnase gibt, die irgendetwas auszusetzen hat.
    - Armin Maiwald
  • Du findest die betreffenden nicht sichtbaren Tabellen hier im zweiten und dritten Beitrag:
    [Basteltechnik] Speedbasteln & Slowbasteln

    Wenn du die betreffenden Beiträge im "bearbeiten"-Modus betrachtest, sollten sie dir angezeigt werden.

    Lustigerweise tauchen sie auch im Quelltext nicht auf.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Yrda ()

  • Hm, hmmmm ...
    Ich guck mal, ob dem Weltenbastler-Benutzer irgendein Recht fehlt.

    Edit: Das ist es mal nicht, und die Forenrechte für Wissenswertes sind auch okay.
    Wenn ich den Beitrag als Admin editiere, habe ich dasselbe Problem wie du. Kurios. Ich schlaf mal drüber.
    Man kann gar nicht so rundum stromlinienförmig sein, dass es nicht irgendeine Pappnase gibt, die irgendetwas auszusetzen hat.
    - Armin Maiwald
  • Hmmmmm ...

    wenn dem Weltenbastler Berechtigungen fehlen, dann fehlen sie mir auch. Zumindest sieht es bei mir genauso aus, wenn ich die Tabelle in meinen Beitrag kopiere. Ich habe sicherheitshalber schon die kleinere genommen, für den Fall, dass es an deren Umfang lag.

    Mit so einer ganz popeligen Test-Tabelle funktioniert es bei mir auch. Aber Mogyus Beitrag zeigt ja, dass auch aufwendigere Tabellen funktionieren. Hmmm.
  • Mal hier testen:

    W6

    W12

    1-3

    4-6

    1

    Tier/Pflanze

    Historisches Ereignis

    2

    Kunstwerk

    Städtisches Wahrzeichen

    3

    Kriminalität

    Krankheit/Leiden

    4

    Konflikt

    Mythologie

    5

    Waffe/Werkzeug

    Persönlichkeit

    6

    Spiel & Sport

    Gilde, Verein, Bündnis

    7

    Gesetz

    Regionale Spezialität

    8

    Landschaftlich markanter Punkt

    Religiöse Zeremonie

    9

    Tracht & Kleidung

    Brauch/Sitte

    10

    Kommunikation & Sprache

    Fortbewegungsmittel

    11

    Magisches/Übernatürliches

    Architektur/Bauten

    12

    Beruf

    Handelsware



    Okay, das hätte ich schneller haben können. Die Tabelle hat nicht validiert, die erste Zeile war kürzer als die anderen. Ich habe eine leere Zelle hinzugefügt und jetzt geht es.
    Man kann gar nicht so rundum stromlinienförmig sein, dass es nicht irgendeine Pappnase gibt, die irgendetwas auszusetzen hat.
    - Armin Maiwald